Sunday, October 14, 2007

久々のupgrade

すごく久々にノートの Debianを upgrade。 ptex-bin が次のようなエラーをだしていた
/var/lib/dpkg/tmp.ci/preinst: 61: mktexlsr: not found
dpkg: error processing /var/cache/apt/archives/ptex-bin_3.1.10~beta3+0.04b-4.1_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 127
もう一度 upgrade したら通ったが、これ(preinstで mktexlsrを実行しちゃってる)は bug じゃないか?
`Pre-Depends' are also required if the `preinst' script depends on the named package. It is best to avoid this situation if possible.